Grupo Lógica de Programação
ESTAMOS EM CONSTRUÇÃO - DESENVOLVIMENTO


Seja Bem Vindo ao Forum Grupo Lógica de Programação é uma satisfação recebê-los aqui.. espero que gostem desse espaço que foi feito para todos nós PROGRAMADORES.. Então venha fazer Parte deste Time tambem.. Saiba que este Forum foi feito com muita dedicação para o bem estar de todos vocês.. Então Registre-se e Decole no Mundo da Programação.....
Ao se Registrar você tem direito a participar do CHAT que só é visivel ao membros registrados. e pode bater papo com algum outro membro que estiver on line.. caso tenha alguma duvida pode olhar no Menu FAQ as perguntas mais recentes.
Bons Estudos é o que deseja todos nós que fazemos o GRUPO LÓGICA DE PROGRAMAÇÃO acontecer...

(EL MENSAJERO [FUNDADOR])

[RESOLVIDO][Ajuda] 0001 - Numeros Inteiros - Soma dos Impares - Divisíveis por 3

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[RESOLVIDO][Ajuda] 0001 - Numeros Inteiros - Soma dos Impares - Divisíveis por 3

Mensagem por Marcos Renan em Qua 13 Jul 2016, 18:55

Ola boa noite to tentando fazer um exercício no visual g e não to tendo sucesso sera que alguém pode me ajudar? Escreva um algoritmo que receba um número inteiro positivo e efetue a soma dos números ímpares que são divisíveis por três e que se encontram no intervalo entre de 1 até esse número.

Marcos Renan
Novo no Fórum
Novo no Fórum

Mensagens : 1
Pontos : 4
Reputação : 0
Data de inscrição : 13/07/2016

Voltar ao Topo Ir em baixo

Re: [RESOLVIDO][Ajuda] 0001 - Numeros Inteiros - Soma dos Impares - Divisíveis por 3

Mensagem por Sergio Lucas em Qui 14 Jul 2016, 05:48

Olá Marcos, qual a dificuldade em fazer o algoritmo?
poderia colocar o que já fez no código?
lembrando que antes de colocar o código, leia [Você precisa estar registrado e conectado para ver este link.] para Postagem correta do Código Fonte aqui no Tópico
avatar
Sergio Lucas
Admin
Admin

Mensagens : 80
Pontos : 308
Reputação : 20
Data de inscrição : 30/06/2010
Idade : 30
Localização : Pernambuco

http://grupologica.forumslog.com

Voltar ao Topo Ir em baixo

Re: [RESOLVIDO][Ajuda] 0001 - Numeros Inteiros - Soma dos Impares - Divisíveis por 3

Mensagem por Sergio Lucas em Qui 28 Jul 2016, 13:40

Devido ao tempo da postagem e ninguém se prontificar em Responder, e nem do usuário informar até que ponto fez o algoritmo, estaremos respondendo, visto que se tratar de um exercício, já passou prazo de entrega, nossa meta é ajudar nas dúvidas que pudermos, porém deve haver esforço e interesse no usuário em aprender, Para isso foi criado o Regulamento do Central de Ajuda [Você precisa estar registrado e conectado para ver este link.]
Segue Abaixo o Codigo, e no final o Link para download do arquivo feito em VISUALG(.ALG)


Código:


Algoritmo "Números Divisiveis por 3 e soma dos Impares"
// Disciplina  :[Linguagem e Lógica de Programação]
// Descrição   : Escreva um algoritmo que receba um número inteiro positivo
//               e efetue a soma dos números ímpares que são divisíveis por
//               três e que se encontram no intervalo entre de 1 até esse
//               número
// Autor(a)    : Sergio Lucas
// Data atual  : 14/07/2016
Var
// Seção de Declarações das variáveis
num,i,calc,soma,cont :inteiro
Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
escreva (" Digite o numero Desejado .: ")
leia(num) //Armazena o número digitado pelo usuário
i<-1
escreval (" Os Números Divisiveis por 3 São: ")
enquanto i<= num faca // Laço de Repetição: Enquanto i for menor ou igual ao
                      // valor digitado Faça os comandos abaixo.
se i MOD 3 = 0 entao  // Estrutura condicional: Se i for Dividido por 3 e o
                      // resto da divisão for = 0 então calc recebe o valor
calc <- i             // de i, ou seja é um numero divisivel por 3
  se calc MOD 2 <> 0 entao // Condicional para verificar se o valor contido
                           // em calc não é divisivel por 2 , o resto da divisão
                           // deve ser diferente de "0" ou seja numero impar
    soma <- calc          // sendo assim soma recebe o valor de calc
    cont<- cont+soma      // cont recebe o valor dele mesmo + valor de soma

  senao               //senao se for divisivel por 2 ele não é um numero impar
    calc <- calc
      fimse      //Fim da condicional para saber se o numero é par ou impar

  escreval ("Numero ",calc) //mostra os numeros que são divisiveis por 3
  fimse  //Fim da condicional que verifica se é divisivel por 3

i<-i+1  // terminando a primeira volta do laço, agora o i recebe o valor dele
        // mesmo + 1 ou seja cada repetição i vai mudar o seu valor até
        // atingir o valor digitado pelo usuário.

 fimenquanto


escreval (" A Soma dos Impares Divisiveis por 3 é.: ",cont) //Finalmente após
// atingir o numero de repetição desejada, é mostrado o valor da soma dos
// números impares que são divisiveis por 3
Fimalgoritmo



BAIXE AQUI O CODIGO FONTE (.ALG)
avatar
Sergio Lucas
Admin
Admin

Mensagens : 80
Pontos : 308
Reputação : 20
Data de inscrição : 30/06/2010
Idade : 30
Localização : Pernambuco

http://grupologica.forumslog.com

Voltar ao Topo Ir em baixo

Re: [RESOLVIDO][Ajuda] 0001 - Numeros Inteiros - Soma dos Impares - Divisíveis por 3

Mensagem por Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum