Grupo Lógica de Programação
ESTAMOS EM CONSTRUÇÃO - DESENVOLVIMENTO


Seja Bem Vindo ao Forum Grupo Lógica de Programação é uma satisfação recebê-los aqui.. espero que gostem desse espaço que foi feito para todos nós PROGRAMADORES.. Então venha fazer Parte deste Time tambem.. Saiba que este Forum foi feito com muita dedicação para o bem estar de todos vocês.. Então Registre-se e Decole no Mundo da Programação.....
Ao se Registrar você tem direito a participar do CHAT que só é visivel ao membros registrados. e pode bater papo com algum outro membro que estiver on line.. caso tenha alguma duvida pode olhar no Menu FAQ as perguntas mais recentes.
Bons Estudos é o que deseja todos nós que fazemos o GRUPO LÓGICA DE PROGRAMAÇÃO acontecer...

(EL MENSAJERO [FUNDADOR])

[RESOLVIDO][AJUDA]- 0002 Converter Pseucodigo VisualG em Python

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[RESOLVIDO][AJUDA]- 0002 Converter Pseucodigo VisualG em Python

Mensagem por Brunosbad em Dom 27 Out 2013, 11:09

Algoritmo "respostas"
var
salario: inteiro
percAumento: real
nome: caracter
inicio
escreva("Informe o nome: ")
leia(nome)
escreva("Informe o salario: ")
leia(salario)
se (salario > 0) e (salario <= 400) entao
percAumento <- 0.15
senao
se (salario >= 401) e (salario <= 700) entao
percAumento <- 0.12
senao
se (salario >= 701) e (salario <= 1000) entao
percAumento <- 0.10
senao
se (salario >= 1001) e (salario <= 1800) entao
percAumento <- 0.07
senao
se (salario >= 1801) e (salario <= 2500) entao
percAumento <- 0.04
senao
se (salario > 2500) entao
percAumento <- 0
senao
escreva("Salario Invalido!!!")
fimse
fimse
fimse
fimse
fimse
fimse
escreva(nome, " - ", percAumento * 100, "% - R$", salario:10:2)
escreva(" - R$", (salario * (1 + percAumento)):10:2)
fimalgoritmo

Brunosbad
Novo no Fórum
Novo no Fórum

Mensagens : 1
Pontos : 8
Reputação : 0
Data de inscrição : 27/10/2013

Voltar ao Topo Ir em baixo

Solução do Problema:

Mensagem por Sergio Lucas em Qua 27 Jul 2016, 22:35

Olá, Devido ao Tempo da Postagem e por nenhum dos membros ou moderadores terem ajudado, estarei resolvendo a questão de acordo com o pedido na Ajuda.
Segue o Código Descrito abaixo, bem como no final da resposta o link para baixar o Código Fonte formato ".Py"

Código:


"""
Descrição  : Faça um Programa que Receba o nome e Salario do funcionario
             o Programa deve calcular o percentual de aumento dessa forma:
             Salario <= 400 - 15%
             Salario >=401 e <= 700 - 12%
             Salario >=701 e <= 1000 -10%
             Salario >=1001 e <=1800 -7%
             Salario >=1801 e <=2500 -4%
             Salario > 2500 - 0%
             Salario que esteja fora dessa faixa deverá ser mostrado a tela de
             salario inválido, no final deve mostrar o nome,percentual
             de aumento , salario antes e após o aumento.

Autor      : Sérgio Lucas
Data       : 27/07/2016
Grupo Logica de Programacao - [Você precisa estar registrado e conectado para ver este link.]

"""

print('----------- CENTRAL DE AJUDA ------------')
print('')
nome = str(input ("Informe o Nome .: "))
salario = float(input ("Informe o Salario .: "))
if salario > 0 and salario <= 400:
    percAumento = 15
elif salario >=401 and salario <= 700:
        percAumento = 12
elif salario >=701 and salario <= 1000:
        percAumento = 10
elif salario >=1001 and salario <=1800:
        percAumento = 7
elif salario >=1801 and salario <=2500:
        percAumento = 4
elif salario > 2500:
        percAumento = 0
else:
    print('Salario Invalido')
print("")
print(nome,"-",percAumento, "% - R$",salario," =  R$ ",
      (salario * percAumento/100)+salario)
print("")
print("By: Sergio Lucas - [Você precisa estar registrado e conectado para ver este link.]
        
        


BAIXE AQUI CODIGO[FONTE]  .PY
avatar
Sergio Lucas
Admin
Admin

Mensagens : 80
Pontos : 308
Reputação : 20
Data de inscrição : 30/06/2010
Idade : 31
Localização : Pernambuco

http://grupologica.forumslog.com

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum